Never forget to attach an important file again.
Attachment Forget-Me-Not
Discount code: BH93RF24

Do not AutoArchive this item checkbox

I have added the column “Do Not AutoArchive” to my Inbox. However, I cannot change the check box from unchecked to checked by clicking on it.

How is this supposed to work?

That option indeed isn’t directly clear as the checkbox looks clickable already when you add the column to your view. However, as you’ve noticed, it isn’t.

Allow in-cell editing

For that function to work directly from your view, you must set your view to “Allow in-cell editing”;

  • Outlook 2003 and Outlook 2007
    View-> Arrange By-> Custom…-> button Other Settings…-> option: Allow in-cell editing
  • Outlook 2010 and Outlook 2013
    tab View-> View Settings-> button Other Settings…-> option: Allow in-cell editing

You can now click on the checkbox directly from your view to easily turn on/off archiving for that item.

Note: You might not actually see a checkbox for your items unless you click on the field itself.

No checkbox or a not-selected checkbox both means that the item will be archived according to your archive settings.