Hidden emails in a shared mailbox

When sharing a mailbox, some of the users accessing this mailbox do not see all messages while others do.

Some other folders even show that there are unread items in them, even though everything has been marked as read or when the folder is empty.

How can I make these "hidden" messages available to everyone?

Hidden Messages buttonThis often happens when those messages have been marked as Private.

When you configure a delegate for your mailbox, by default this delegate is not allowed to see any items that have been marked as private.

Verify sensitivity level of a message

To see if a message indeed got hidden because of its sensitivity level being set to Private, you can select the message and press ALT+ENTER.

This will bring up the properties window of that message. At the bottom right, you’ll find the sensitivity level. This can be either Normal, Personal, Private or Confidential. You cannot change the sensitivity level for received messages.

Allow delegates to see private items

Delegates buttonTo allow a delegate to see private items as well you can do the following;

  1. Open the Delegate permissions dialog;
    • Outlook 2007
      Tools-> Options…-> tab Delegates
    • Outlook 2010 / 2013 / 2016 / 2019 / Office 365
      Select the Inbox of your Exchange account.
      File-> button: Account Settings-> button: Delegate Access
  2. Double click or add the delegate that you also want see private items.
  3. In the Delegate Permissions dialog for that person select the option;
    Delegate can see my private items

Delegate can see my private items
Enabling delegate access to private items.

Note: The option to see private items applies to all items in the mailbox the delegate has access to and not just the Inbox folders. So if you have Calendar items marked as private, the delegate would be able to see these items now as well.

Use "4PM76A8" to get a discount when ordering!