Don’t convert drive path to UNC path

When inserting a link to a file on a mapped network share, the link is automatically converted to a UNC path. So a link that used to be;
turns to;

In the above example the H:\-drive is the user’s home drive and the UNC path now points to the home location of the sender instead of the receiver.

This is causing us some issues as we often place personal report files on the user’s home drive and then send them an email with a link to notify them of this. Our Human Resource department for instance does this in bulk and sends out a standardized email to all of the users at once with the H:\-drive reference.

Is there a way to configure Outlook that the drive path reference to the mapped network share is kept and that it won’t be converted to a UNC path?

Sadly, there is no direct solution for this issue but there are a couple of workarounds;

Type the link

Instead of using Insert-> Hyperlink to link a specific word such as “click here to open the document” you can type the link instead.
To have it turn into a link automatically use the following format;

For this method you’ll have to be aware of spaces in the filename and place the link between < and > if necessary or you’ll end up with a broken hyperlink.

This trick however does not work in Outlook 2003 with Word set as your e-mail editor as it even converts typed links into UNC paths.

Compose in Plain Text

When you compose your message in Plain Text and type the link, the link will remain intact as it is based on what it written in text and there is nothing going on “behind the text”.

Note: Even though with Word set as the e-mail editor the tooltip will still show it as a UNC path, the link which is actually being received will remain the drive path and thus still works.

Again, for this method you’ll have to be aware of spaces in the filename and place the link between < and > if necessary. Also, for Outlook to convert typed links in Plain Text messages to actual clickable links, the receiver needs to have that specific AutoFormat option enabled (which is the default).

Set Outlook as your e-mail editor

A workaround specifically for Outlook 2003 and previous is to set Outlook as the e-mail editor instead of Word. To change this go to:
Tools-> Options…-> tab Mail Format

Temporarily disconnect the mapped drive

A bit more drastic approach is to temporarily disconnect your mapped network drive. This will also allow you to link specific words to a location again as mentioned above. The trick behind this is that upon creating the hyperlink, the UNC path cannot be resolved and thus the link will remain intact.

When using the Insert-> Hyperlink option, you’ll have to type the path of course as you can no longer browse to the file.

Be careful that when you disconnect the mapped network drive you don’t have any documents open in any application that are stored in that location.

Inject the HTML source

A bit inconvenient perhaps but still a good workaround, especially when you work with templates, is to directly inject the HTML source into the message that you are composing. This of course requires you to type the template in a proper HTML editor or manually construct the HTML source code.

Basically it suffices to create a txt file with just the following in it;

    <a href="file://H:/filename.txt">click here</a>
Use "4PM76A8" to get a discount when ordering!