Automatically save attachments to a Windows folder.
Attachment Save
Discount code: BH93RF24

ActiveX error for emails

I receive the following errors when viewing or creating several emails;

“One or more Active X controls could not be displayed.”
“Your current security settings prohibit running ActiveX controls on this page. As a result, the page may not display correctly.”

Which security settings do I need to change for this?

Actually your security settings are set correctly as ActiveX controls shouldn’t be used for emails.

What is happening here is that somewhere when composing the email these ActiveX controls were added to the email. Assuming that you are the composer of the email, the most likely cause is that you are using Word as your email editor or have created your email signature in Word. Certain advanced text effects are achieved in Word by the use of ActiveX controls. Another possibility is that you have installed an add-in in Word which modified your normal.dot file which is also being used when creating an email in Outlook 2003 or previous when using Word as your email editor.

Signature

Turn off your default signature and see if you still get the error message when creating a new message or when somebody receives a message from you (you can send yourself a test message as well). If not, the ActiveX control was in your signature and should be recreated.

Change your email editor

Turn off Word as your email editor (Outlook 2003 and previous) and see if you still get the error message when creating a new message or when somebody receives a message from you. If not, the ActiveX control is within your normal.dot file.

Reset normal.dot

If you are using Outlook 2003 or previous with Word as your email editor you can reset normal.dot by renaming it to .old when Word and Outlook are closed. You can find it here;

  • Windows 7 and Windows Vista
    C:\Users\%username%\AppData\Roaming\Microsoft\Templates\
  • Windows XP
    C:\Documents and Settings\%username%\Application Data\Microsoft\Templates\

Stationery and Themes

If you have a default Stationery or Theme selected, set it to default again. If you no longer get the error, verify the stationery or theme that you were using that they are clear of any ActiveX components.

Word Add-ins

If you are still having the issue after checking all of the above, then the issue is very likely caused by quite a persistent Word add-in (Outlook 2003 and previous only). Disable all your Word add-ins and enable them one by one (restarting both Word and Outlook in between) to find the culprit.

Disable Add-ins in Word

Word 2003 and previous;

  1. Tools-> Customize…-> tab Commands
  2. In the left list select Tools
  3. From the right list drag and drop the “COM Add-ins…” command to your toolbar
  4. Close the current dialog an press the COM Add-ins button

Word 2007 and Word 2010
As mentioned before the ActiveX issue shouldn’t be caused by Word add-ins in Outlook 2007 or Outlook 2010 as they are only loaded in and not in Outlook. The instructions are added just to be complete;

  1. Open the Options dialog of Word
    • Word 2007
      Office button in the left top corner-> button Word Options
    • Word 2010
      File-> Options
  2. Select the Add-Ins section on the left.
  3. From the Manage list at the bottom select COM Add-Ins and press the button Go…

If you get an error when disabling an add-in use the procedure indicated in this post to start Word as an administrator but then of course applied to Word and not Outlook ;-)



ABF Outlook Backup
Use "ABF-HT2GL" to get a discount when ordering!