Real World Questions, Real World Answers
Share your Outlook calendars, contacts, emails and tasks
in real-time without Exchange Server.
CodeTwo Public Folders

New Appointment defaults to All Day Event

When I create a new appointment in my Calendar, it defaults to creating an “All day event” and doesn’t allow me to schedule a time unless I untick the “All day event” checkbox.

What do I need to change so that the new appointments don’t have the “All day event” checkbox selected by default?

New Appointment buttonWhen your Calendar view is set to “Month” and you double click on a specific day to schedule a new appointment on that day, the default is an “All day event” since you clicked on an entire day.

To work around this, first select the day that you want to create the appointment on and then click on the “New Appointment” or “New Meeting” button.

This way, the “All Day Event” option won’t be selected and instead the starting time will match the start time of your configured “Work hours”, the duration is set to 30 minutes and of course the currently selected date is filled out automatically as well.

Double clicking on a day within the Month view creates an All Day Event.
Double clicking on a day within the Month view creates an All Day Event.

Day, Week or Month view

Time Scale buttonAnother way to go would be to set your view to the Day, Work Week or Week view instead of the Month view.

When you’d then double click on a time-slot in your Calendar, the new appointment will automatically have the selected time filled out as the starting time and the duration is set to what you have selected as the Time Scale for your Calendar.

So when you have the Time Scale for your Calendar set to 60 minutes, it will create an appointment for 1 hour and when you have the Time Scale set to 30 minutes, the duration is set to half an hour.

This is actually also the reason why the Month view produces All Day Events by default since the Time Scale is then basically set to an entire day.

Use "4PM76A8" to get a discount when ordering!