Backup add-in remembers old location

I’ve use the Personal Folders Backup add-in to regularly back-up my pst-files. I’ve recently changed my backup location and also configured the backup add-in to use that new location. However, it still is looking for the old location which no longer exists.

How can I make the back-up add-in no longer look for this location?

The Personal Folders Backup add-in from Microsoft stores the backup location in the pst-file itself. For some reason it apparently added the new backup location instead of replacing the old. Recovering from this is a bit tricky but not impossible.

Delete the old location setting with MFCMAPI

Before you get started with the fix, make sure you make a good backup of your pst-file first (I know, there is some irony to that…).

  1. Since the backup location is stored as a property  within the pst-file itself, we’ll need a tool that can edit these properties. I use MFCMAPI for this which is a free tool hosted on CodePlex which is the Open Source Community from Microsoft.
  2. Start MFCMapi.exe
  3. In the main window choose;
    Session-> Logon and Display Store Table
  4. Select the Outlook mail profile to logon to when prompted.
    If you do not recognize this dialog, simply press OK to load you default Outlook mail profile.
  5. You’ll now see a list of your configured pst-file in your mail profile.
    Select the pst-file for which you want to change the backup location of.
  6. In the pane below, some properties will get loaded.
    Look at the Value column to find the property that holds the old backup location. Right click on this property and choose: Delete Property
  7. Confirm the warning; “This will permanently delete this property from the item.”
  8. Log off your session via;
    Session-> Logoff

Removing the back-up location with MFCMAPI
Removing the back-up location with MFCMAPI

Note: If you can’t seem to turn off backing up a certain pst-file, you can use the same method as described above but then at step 6, scroll the bottom pane all the way to the right and delete all properties which have the Named Prop GUID value of;
{8F93C891-20C3-11D2-954D-0060979392B4}