Clicking on hyperlink opens my Documents folder

When I click on a hyperlink in a message it opens a dialog showing my computer folders (defaulting to My Documents). I don’t want to save it.

How can I get it to open the website instead?

Is the dialog window called Locate Link Browser? Point it to IEXPLORE.EXE and press OK.

You can find it in the following location;

  • Windows 32-bit
    C:\Program Files\Internet Explorer
  • Windows 64-bit
    C:\Program Files (x86)\Internet Explorer

If it continues to happen choose Start-> Control Panel-> Default Programs and Settings to reset Internet Explorer or FireFox (or any other browser that you prefer to use as default) as the default browser.

Yet another way to reset the hyperlink clicking behavior is to use the Registry fix offered in the Quick Tip; This operation has been cancelled due to restrictions in effect on this computer

Locate Link Browser dialog. (click on image to enlarge)
Locate Link Browser dialog. (click on image to enlarge)

Not using Internet Explorer and DDE configuration

If you are not using Internet Explorer as your default browser, this dialog could return when opening a link or the link could be opened twice. To prevent this, you must disable the DDE option for the “URL:HyperText Transfer Protocol” and the “URL:HyperText Transfer Protocol with Privacy” file type.

Windows XP
In this version of Windows, you can make the change via the Folder Options applet in Control Panel but you can also use the solution for Windows Vista and Windows 7 listed below.

  1. Start-> Control Panel-> Folder Options tab File Types
  2. In the left column, you’ll find a list with the Extension of (NONE). Here, look for the entry that has “URL:HyperText Transfer Protocol” in the right File Types column.
  3. Select this entry and click on the Advanced button in the bottom right corner.
  4. Double click on the “Open” action or press the Edit… button.
  5. Uncheck the checkbox for the “Use DDE option”.
  6. Press OK and OK again to return to the Folder Options dialog.
  7. Repeat step 2-6 for the “URL:HyperText Transfer Protocol with Privacy” file type.
  8. Press OK to close the Folder Options dialog.

Windows Vista and Windows 7
These versions of Windows no longer have the File Types tab in the Folder Options dialog. In order to make the change, you’ll have to remove the following keys from the Registry.

  • HKEY_CLASSES_ROOT\HTTP\shell\open\ddeexec
  • HKEY_CLASSES_ROOT\HTTPS\shell\open\ddeexec
  • HKEY_CLASSES_ROOT\FirefoxURL\shell\open\ddeexec
  • HKEY_CLASSES_ROOT\FirefoxHTML\shell\open\ddeexec

To make these changes without going into the Registry yourself, you can download this registry file and execute the openlinkbrowser-fix.reg file.

MAPILab
Use "4PM76A8" to get a discount when ordering!