Issues opening Excel attachments

When I double click on an Excel attachment, Excel opens but it doesn’t open the spreadsheet or I get an error. Other attachments open just fine.

How can I fix this?

This often happens when Excel is set to ignore other applications or when Outlook’s Secure Temp folder is “full”.

Excel is set to ignore other applications

The most common cause is that Excel has been configured to ignore other applications. This is an option that is disabled by default but can be enabled to isolate the Excel working environment. When the option is enabled, you can only open Excel attachments from within Excel itself.

To disable this option you can do the following;

  • Excel 2003 and previous
    Tools-> Options…-> tab General-> option: Ignore other applications
  • Excel 2007
    Office logo (left top)-> Excel Options-> section Advanced-> option group: General-> option: Ignore other applications that use Dynamic Data Exchange (DDE)
  • Excel 2010
    File-> Options-> section Advanced-> option group: General-> option: Ignore other applications that use Dynamic Data Exchange (DDE)

After setting this option, close Excel. When you now double click on the attachment, it should open as expected.

Ignore other applications that use Dynamic Data Exchange (DDE)
When the option to ignore other applications is set,
attachments will not open in Excel.

Clear Outlook’s Secure Temp folder

Another possible cause that Excel attachments are not opening correctly or with an error is because of other Excel files or templates in Outlook’s Secure Temp folder. The Secure Temp folder is the folder that Outlook uses to (temporarily) store attachments to that are being opened directly from within Outlook. Under certain conditions, this Secure Temp folder is not always cleaned correctly. In that case, you can clean it manually and see if the attachment is opened correctly now.

For instructions to clear Outlook’s Secure Temp folder see; Cleaning out the Temporary Outlook Files folder

MAPILab
Use "4PM76A8" to get a discount when ordering!