Importing contacts from an exported csv-file fails

I’ve exported my contacts from Windows Live Mail on my old computer and now I want to import them into Outlook on my new computer.

The file is in csv-format but when I try to import it into Outlook, I’m being prompted to Map Custom Fields but everything is just on a single line.

How can I import my contacts into Outlook?

Import CSV buttonI’m not sure whether I should call this a bug or a feature but luckily the solution is quite easy.

For a change, let’s start with the solution and then I’ll explain my dilemma of whether to call this a bug or a feature.

Solution

The issue is that instead of commas ( , ) being used as a separator, you probably see semi-colons ( ; ) being used instead. So replace the semi-colons for commas and you’re done. The easiest is to do this in Notepad;

  1. Open Notepad.
  2. Edit-> Replace…
  3. Find what: ;
    Replace with: ,
  4. Press Replace All.
  5. Save the file and close Notepad.
  6. Go back to Outlook and import the file.

Notepad - Using the Replace function to fix a comma separated value file (csv).
Turning a semi-colon separated file into a proper comma
separated file can be done easily via Notepad.

The bug or feature dilemma

Bug? buttonThe reason why Windows Live Mail (WLM), and also Outlook Express (OE) and Windows Mail (WM), used a semi-colon as a separator instead of a comma is because that is what is specified in your Region Settings in Windows to be used as the list separator. If this was set to a comma, you probably wouldn’t have been reading this ;-)

Outlook however expects a comma as a separator in a csv-file as that is what the file format stands for; comma separated value. Should WLM, OE or WM look at your configured list separator instead and use that? Should Outlook? It would break interoperability between systems if the format of a file is depended on end-user configuration. Are WLM, OE and WM to blame here for not respecting the meaning of csv? In essence, WLM, OE and WM export to the dsv-format; delimiter separated value. In this format the choice of the delimiter is not restricted to a comma.

However, as I said, you can configure the delimiter in your Regional Settings in Windows which would make it a feature again and will enable to WLM, OE and WM to create a proper csv-file again.

To change your list separator value in Windows;

  1. Open Control Panel from the Start Menu or via a Search.
    • In Windows 10 you can also choose;
      Start-> Settings->  Time & Language-> scroll down and click on: Additional date, time, & regional settings
  2. Open the Region and Language Options applet.
    • Windows XP Category view
      Date, Time, Language, and Regional Options.
    • Windows Vista, Windows 7, Windows 8 and Windows 10
      Clock, Language and Region-> Change date, time, or number formats
  3. On the Formats tab click; Customize this format… or Additional settings…
  4. In the drop down list for List separator you can either select the comma or type it in the box if it is not listed.
  5. Now, when you export from WLM, OE or WM, you’ll create a proper csv-file.

Selecting the default List Separator in the Region settings of Windows.
Selecting the default List Separator in the Region settings of Windows.

So, would you call it a bug or a feature? Should WLM, OE and WM always use the comma and not look at your list separator value or should they rename the file format to dsv instead?

I think I’d prefer the first solution as that is what Outlook expects as well when importing and that is simply what the csv-format stands for. The thing is, files with another delimiter than a comma usually are named *.csv as well so the confusion remains when getting another file for import.

My advise

Important buttonAlways double check the delimiter being used before importing anything.

If the delimiter is not what is being expected and you cannot configure the delimiter upon importing (like Excel exports), then fire up Notepad and use its Replace function.

The dilemma might be complex, but at least the workaround is easy ;-)

Sperry Software
Use "BH93RF24" to get a discount when ordering!